
CBSE Sample Papers for Class 10 IT Set 2 
with Solutions 

Time: 2 Hours 

Maximum Marks: 50 

Instructions: 

 Please read the instructions carefully. 

 This Question Paper consists of 21 questions in two sections: Section A & Section B. 

 Section A has Objective Type Questions whereas Section B contains Subjective Type 

Questions. 

 Out of the given (5 + 16 = 21) questions, a candidate has to answer (5 + 10 = 15) 

questions in the allotted (maximum) time of 2 hours. 

 All questions of a particular section must be attempted in the correct order. 

 Section A: Objective Type Questions (24 Marks) 

 This section has 5 questions. 

 Marks allotted are mentioned against each question/part. 

 There is no negative marking. 

 Do as per the instructions given. 

 Section B: Subjective Type Questions (26 Marks) 

 This section has 16 questions. 

 A candidate has to do 10 questions. 

 Do as per the instructions given. 

 Marks allotted are mentioned against each question/part. 

Section A 

Objective Type Questions [24 Marks] 

Question 1. 

Answer any 4 out of the given 6 questions on Employability Skills. (4×1=4) 

(i) Samar wrote a notice full of difficult words and unclear instructions. Many students 

ignored it. Which principle of communication was violated? 

(a) Concreteness 

(b) Conciseness 

(c) Clarity 

(d) Completeness 

Answer: 

(c) Clarity 

(ii) (ii) Which of the following is the most suitable term for managing stress through 

regular walking in a natural environment? 

(a) Physical fitness 

(b) Nature walk 

(c) Morning exercise 

(d) Forest workout 

Answer: 

(b) Nature walk 

(iii) Arjun studies regularly, stays focused on his goals, and encourages himself even when 

results aren‘t immediate. This shows: 

(a) carelessness 

(b) laziness 

(c) self-motivation 

(d) distraction 

Answer: 

(c) self-motivation 



 (iv) A good way to protect your system from viruses is to 

(a) ignore software updates. 

(b) open all email attachments. 

(c) use antivirus software and scan regularly. 

(d) keep the computer always turned off. 

Answer: 

(c) use antivirus software and scan regularly. 

(v) One of the key roles of an entrepreneur in society is to 

(a) avoid competition 

(b) reduce employment opportunities 

(c) promote social and economic development 

(d) work in a bank 

Answer: 

(c) promote social and economic development. 

(vi) Which one of these models best supports sustainable living? 

(a) Diesel generator 

(b) Solar cooker 

(c) Plastic incinerator 

(d) Coal heater 

Answer: 

(b) Solar cooker 

A Mistake Alert 

Students may confuse with ―Plastic incinerator‖ or ―Diesel generator‖ due to their wide use, 

but these are non-sustainable. 

Question 2. 

Answer any 5 out of the given 6 questions. (5×1=5) 

(i) Preeti wants to apply the same formatting from one paragraph to another quickly. Which 

feature should she use? 

(a) Format Paint 

(b) Fill Format 

(c) Clone Formatting 

(d) Copy-Paste 

Answer: 

(b) Fill Format 

 (ii) Rahul inserted an image in his document but wants to wrap text tightly around it. Which 

option should he use? 

(a) In Background 

(b) Page Wrap 

(c) Optimal Page Wrap 

(d) Through 

Answer: 

(c) Optimal Page Wrap 

(iii) Which of the following is a category of style in Writer? 

(a) Shape Style 

(b) Image Style 

(c) Frame Style 

(d) Caption Style 

Answer: 

(c) Frame Style 



(iv) Which menu is used to insert a Table of Contents in Writer? 

(a) Insert → Indexes and Tables 

(b) View → Navigator 

(c) Tools → AutoText 

(d) Format → Table of Contents 

Answer: 

(a) Insert → Indexes and Tables 

 (v) What is the use of a template in LibreOffice Writer? 

(a) To save passwords 

(b) To create identical charts 

(c) To reuse predefined document formats 

(d) To organise menus 

Answer: 

(c) To reuse predefined document formats 

(vi) Jyoti is preparing a school magazine using a template. She wants to apply a different 

template to a blank document. Which option should she use? 

(a) Import Template 

(b) Export Template 

(c) Apply Template 

(d) Insert Template 

Answer: 

(c) Apply Template 
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Question 3. 

Answer any 5 out of the given 6 questions. (5×1=5) 

 (i) In Calc, which tool lets you test formulas under different scenarios? 

(a) Goal Seek 

(b) Solver 

(c) Scenario Manager 

(d) Filter 

Answer: 

(c) Scenario Manager 

(ii) In a shared spreadsheet, which action shows all previous edits? 

(a) Accept Change 

(b) Show Changes 

(c) Update Sheet 

(d) Sort Data 

Answer: 

(b) Show Changes 

(iii) A macro can be created using 

(a) Tools → Macros → Record Macro 

(b) Edit → Macros 

(c) Data → Macro Tool 

(d) Insert → Record 

Answer: 

(a) Tools → Macros → Record Macro 

 (iv) Which hyperlink allows connection to a data source? 

(a) Web link 

(b) Document link 



(c) Registered data source link 

(d) Text link 

Answer: 

(c) Registered data source link 

(v) Which Calc feature consolidates data from multiple ranges? 

(a) Group 

(b) Chart 

(c) Consolidate 

(d) Solver 

Answer: 

(c) Consolidate 

(vi) Which menu lets you create a scenario in Calc? 

(a) Data → Scenario 

(b) Insert → Scenario 

(c) Tools → Scenario 

(d) Format → Scenario 

Answer: 

(a) Data → Scenario 

Question 4. 

Answer any 5 out of the given 6 questions. (5×1=5) 

(i) Priya is designing a database of student details. She wants to ensure each record is 

uniquely identified. Which action should she take while creating the table in design view? 

(a) Sort the records 

(b) Set a primary key 

(c) Hide duplicate fields 

(d) Apply referential integrity 

Answer: 

(b) Set a primary key 

(ii) Which tool in LibreOffice Base is used to display selected data from one or more tables 

based on specific conditions? 

(a) Report 

(b) Query 

(c) Form 

(d) Filter Wizard 

Answer: 

(b) Query 

(iii) What does referential integrity ensure in relational databases? 

(a) Data is sorted alphabetically. 

(b) All linked tables are deleted. 

(c) Consistent and valid relationships between tables. 

(d) All data is converted to text. 

Answer: 

(c) Consistent and valid relationships between tables 

 (iv) In LibreOffice Base, which object is used to display the final formatted output for 

printing? 

(a) Query 

(b) Table 

(c) Form 

(d) Report 



Answer: 

(d) Report 

(v) Which of the following is not an object of LibreOffice Base? 

(a) Table 

(b) Form 

(c) Slide 

(d) Query 

Answer: 

(c) Slide 

(vi) While editing a form in LibreOffice Base, Meena wants to display a fixed text title at the 

top of the form. Which form control should she insert? 

(a) Date Field 

(b) Label 

(c) Text Box 

(d) Numeric Field 

Answer: 

(b) Label 

Question 5. 

Answer any 5 out of the given 6 questions. (5×1=5) 

(i) Priya works long hours on a computer without adjusting screen brightness or taking 

breaks. She starts experiencing blurry vision and eye strain. Which safety measure could 

reduce this? 

(a) Use a dark background wallpaper 

(b) Lower the monitor below eye level 

(c) Take frequent eye breaks and adjust monitor brightness 

(d) Increase screen resolution to maximum 

Answer: 

(c) Take frequent eye breaks and adjust monitor brightness 

 (ii) ………. is the science that focuses on designing tools and workspaces to fit human needs 

and prevent strain. 

(a) Physiology 

(b) Ergonomics 

(c) Kinesiology 

(d) Automation 

Answer: 

(b) Ergonomics 

(iii) Which of the following is not a physical hazard in the workplace? 

(a) Poor ventilation 

(b) Loud noise 

(c) Bright lighting 

(d) Delayed email response 

Answer: 

(d) Delayed email response 

(iv) The purpose of workplace safety policies is to 

(a) increase workload 

(b) reduce worker rights 

(c) prevent accidents and injuries 

(d) promote overtime 



Answer: 

(c) prevent accidents and injuries 

(v) A slippery floor, uncovered wires, and poor lighting are examples of 

(a) Chemical hazards 

(b) Biological hazards 

(c) Physical hazards 

(d) Visual hazards 

Answer: 

(c) Physical hazards 

(vi) Which of the following should not be done while working on electrical equipment? 

(a) Wear dry gloves 

(b) Work with wet hands 

(c) Use insulated tools 

(d) Switch off power before repairing 

Answer: 

(b) Work with wet hands 

Section B 

Subjective Type Questions [26 Marks] 

Answer any 3 out of the given 5 questions on Employability Skills. Answer each question in 

20-30 words. (3×2=6) 

Question 6. 

What are two ways to overcome communication barriers? 

Answer: 

One way to overcome communication barriers is by using simple and clear language that is 

easy to understand. Another way is through active listening, which means paying full 

attention to the speaker without interrupting. Both methods help reduce misunderstandings 

and improve effective communication. 

Question 7. 

What is stress management and why is it important? 

Answer: 

Stress management involves techniques and practices that help a person cope with stress in a 

healthy way. It is important because unmanaged stress can lead to physical and mental health 

issues. Managing stress effectively improves concentration, productivity, emotional balance 

and overall well-being in personal and professional life 

Question 8. 

What is the purpose of installing antivirus software on a computer? 

Answer: 

Antivirus software protects a computer from maiware, viruses, spyware and other malicious 

threats. It scans files and programs, prevents unauthorjsed access and alerts the user to 

suspicious activity. Regularly updated antivirus ensures data security and helps maintain the 

computer‘s smooth arid safe operation. 

Question 9. 

What is the role of entrepreneurship in society? 

Answer: 

Entrepreneurship promotes economic development. creates jobs and introduces innovations 

that improve the quality of life. Entrepreneurs solve local problems with creative solutions 

and contribute to community welfare by supporting infrastructure, education and 

sustainability. 
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Question 10. 

Explain any two problems related to sustainable development. 

Answer: 

Two major problems are: 

 Overuse of natural resources, which leads to deforestation, soil erosion and depletion 

of minerals; 

 Pollution, including air, water, and land pollution, which harms health and 

biodiversity making it harder to maintain ecological balance. 

Answer any 4 out of the given 6 questions in 20-30 words each (4×2=8) 

Question 11. 

What is meant by the ‗Track Changes‘ feature in Writer and when is it useful? 

Answer: 

Track Changes in Writer is a feature that records all modifications made to a document. such 

as deletions, insertions and formatting updates. It is especially useful during document 

reviews or collaborations. Reviewers can suggest changes, and the author can later accept Or 

reject them, ensuring controlled and transparent editing. 

Question 12. 

Explain the function of the What-if Analysis tool in Calc. 

Answer: 

The What-if Analysis tool in Caic allows users to see how changes in input values affect the 

outcome of formulas. For example, if you‘re calculating profit based on selling price and 

quantity, you can test different prices to see how profits change. This tool is useful for 

decision-making, budgeting and forecasting. 

Question 13. 

How can you edit a hyperlink in Calc? 

Answer: 

To edit a hyperlink in Calc, tight-click the hyperlink and choose Edit Hyperlink. A dialog box 

appears where you can change the link‘s 

target, text or type (e.g., IJRL document, email). Editing hyperlinks helps ensure accuracy 

and maintain relevance if file locations or linked documents change. 

Question 14. 

Define Relational Database Management System (RDBMS). Give two examples of its 

objects. 

Answer: 

A Relational Database Management System (RDBMS) stores data in related tables. It uses 

structured relationships based on keys (primary and foreign) to manage data efficiently and 

eliminate redundancy. Examples of objects in an RDBMS include tables (which store the 

data), queries (used to retrieve specific information), forms (used for user-friendly data entry) 

and reports (used Ior‘formatted output and printing purposes). 

Question 15. 

What are two common physical hazards found in office environments? 

Answer: 

Slipping on wet floors and tripping over cables or loose carpeting are common physical 

hazards in offices. These hazards can lead to injuries like sprains, fractures or even head 

trauma. Ensuring clean, dry floors and properly managed wires can significantly reduce these 

risks, Regular inspections and proper signage also help maintain a safe work setting. 



Question 16. 

What are the basic guidelines for maintaining good air and water quality in the workplace? 

Answer: 

Air quality can be maintained by ensuring proper ventilation, using air purifiers and keeping 

the workspace dust-free. Avoiding chemical pollutants and regular HVAC maintenance is 

essential. For clean water, ensure regular testing, proper filtration and accessible sanitation 

facilities. Promoting a clean, hygienic environment supports the overall health and safely of 

employees. 

Answer any 3 out of the given 5 questions in 50-80 words each. (3×4=12) 

Question 17. 

(a) What is the benefit of using the Fill Format mode in Styles and Formatting? 

Answer: 

The Fill Format mode in LibreOffice Writer allows users to apply a selected style to multiple 

sections of the document quickly. Once the mode is activated, the chosen style can be 

―painted‖ onto different text blocks or elements simply by clicking. This is particularly useful 

for maintaining consistency in formatting, especially when editing large documents. It saves 

time and ensures that the formatting stays uniform throughout the file. 

(b) How does anchoring help in positioning images within text in Writer? 

Answer: 

Anchoring in LibreOffìce Writer determines how an image is connected to a particular part of 

the document. You can anchor an image to a paragraph. character, or page. This setting 

ensures that the image moves appropriately when the text is edited. For example, anchoring 

to a paragraph keeps the image with that paragraph. while anchoring to the page keeps the 

image fixed in one location. It helps maintain the layout and flow of the document. 

Question 18. 

Mrs. Reema, the Head of the Academic Department at Sunrise School, is preparing the 

annual academic performance report. Each subject teacher has maintained their own 

spreadsheet for student marks in different worksheets. Mrs. Reema now wants to combine all 

subject-wise data, automate repetitive entries, analyse results using scenarios, and collaborate 

with teachers by tracking their feedback and suggestions. 

(a) Which feature should Mrs. Reema use to combine student marks from different subject 

worksheets into one final result sheet? 

(b) To automate the task of entering common remarks like ‗Passed‘ or ‗Needs Improvement‘ 

for multiple students, which tool should she use? 

(c) Mrs. Reema wants to evaluate how the overall class result changes if passing criteria are 

modified from 35 to 40 marks. Which tool will help her simulate and compare this? 

(d) Since the final report is shared among subject teachers for review, how can Mrs. Reema 

ensure all edits and suggestions made by them are tracked? 

Answer: 

(a) Mrs. Reema should use the ‗Consolidate‘ feature found under Data →Consolidate. This 

allows her to select each subject sheet as a data source and apply functions like Sum or 

Average to summarise student marks in one central location. 
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(b) She can record a Macro using Tools → Macros → Record Macro, where she enters the 

remark once. Later, she can run this macro repeatedly, saving time and avoiding manual 

errors while adding feedback across rows. 

(c) She should use the What-if Scenarios feature available under Tools → Scenarios. By 

creating different scenarios like ―Pass at 35 marks‖ and ―Pass at 40 marks,‖ she can instantly 

switch views and analyse the impact on the overall class result. 



(d) She can enable Track Changes from Edit → Track Changes → Record. This records all 

changes made by teachers. Later, she can review them under Edit → Track Changes → 

Manage Changes, where she can Accept or Reject each change. 

Question 19. 

A worker accidentally drops a heavy object on his foot. As a safety officer, you need to 

educate others on how to handle such emergencies and the importance of reporting. 

(a) What two actions should you take when an accident occurs at work? 

Answer: 

When an accident happens, immediately help the injured employee and ensure their safety. If 

the inlury is serious, call for medical help without delay, Next, report the incident to the 

supervisor with complete details, including how and where it happened. If possible, isolate 

the accident area to prevent others from being hurt harm and ensures proper care and 

investigation of the event. 

(b) Why is it important to follow accident-reporting procedures? 

Answer: 

Following accident-reporting procedures helps identify workplace hazards and prevent them 

in the future. It ensures the injured person receives proper care and support. Timely reporting 

is also essential for legal compliance and helps the organisation maintain a safe working 

environment. Proper documentation helps with insurance claims and future safety training. 

Ignoring accidents or delaying reports can lead to serious consequences for both employees 

and employers. 

Question 20. 

(a) What are queries in LibreOffice Base? Why are they used? 

Answer: 

Queries are used to extract specific information from a database by applying criteria and 

filters. The alois‘ users to view. update. or surnmarise data across one or more tables. For 

instance, a user can create a query to find ‗tudents scoring above 90%. Queries are essential 

tools in data analysis and reporting, making large data sets easier to manage and interpret. 

(b) How can you create a query using the design view in Base? 

Answer: 

In design vie users manually select tables and fields to include in the quer then specify 

conditions, sorting and grouping. This method 

gives greater control and flexibility compared to the wizard. It is especially useful for 

complex queries involving multiple tables, calculated fields and logical expressions. The 

design grid allows visual arrangement of fields and conditions, making it efficient for precise 

data retrieval. 

Question 21. 

Consider the following table: 

Reg_No Name Room_No Contact 

HS101 

HS102 

HS103 

Rohit 

Meena 

Rohit 

12 

14 

12 

9123456780 

9234567890 

9345678901 



(a) Suggest a suitable data type for the Reg_No and Room_No. 

Answer: 

Data Trpes 

 Reg_No → Text (e.g.. ―HS101‖ – alphanumeric, no calculations needed). 

 Room_No → Number (e.g., 12 — numeric, allows sorting/range queries). 

(b) Which field should be set as the primary key and why? 

Answer: 

Primary Key 

 Reg_No 

 Each Reg…No is unique (no duplicates), ensuring no two students share the same ID. 

(c) Identify a possible alternate key and justify. 

Answer: 

Alternate Key 

 Contact 

 Contad numbers are unique in this table (no duplicates) 

(d) How many attributes and records are present? 

Answer: 

Attributes and Records 

 4 Attributes (columns) Reg.No. Name, Rom_No, Contact. 

 3 Records (rows) Entries for HS101, HS102, H5103. 
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Instructions: 

 Please read the instructions carefully. 

 This Question Paper consists of 21 questions in two sections: Section A & Section B. 

 Section A has Objective Type Questions whereas Section B contains Subjective Type 

Questions. 

 Out of the given (5 + 16 = 21) questions, a candidate has to answer (5 + 10 = 15) 

questions in the allotted (maximum) time of 2 hours. 

 All questions of a particular section must be attempted in the correct order. 

 Section A: Objective Type Questions (24 Marks) 

 This section has 5 questions. 

 Marks allotted are mentioned against each question/part. 

 There is no negative marking. 

 Do as per the instructions given. 

 Section B: Subjective Type Questions (26 Marks) 

 This section has 16 questions. 

 A candidate has to do 10 questions. 

 Do as per the instructions given. 

 Marks allotted are mentioned against each question/part. 

Section A 

Objective Type Questions [24 Marks] 

Question 1. 

Answer any 4 out of the given 6 questions on Employability Skills (4×1=4) 

(i) After submitting a report, Neha received comments like ―Your analysis in Section 2 is 

very clear and well-supported by data.‖ 

What kind of feedback did Neha receive? 

(a) Specific and descriptive 

(b) Non-verbal and general 

(c) Vague and indirect 

(d) Verbal and emotional 

Answer: 

(a) Specific and descriptive 

 

(ii) What is the first step in managing time effectively? 

(a) Avoiding planning 

(b) Identifying and prioritising tasks 

(c) Ignoring deadlines 

(d) Doing everything at once 

Answer: 

(b) Identifying and prioritising tasks 

(iii) Ananya takes deep breaths and practices meditation for 10 minutes before every exam to 

calm her mind. This is an example of 



(a) self-motivation 

(b) emotional intelligence 

(c) stress management technique 

(d) time management 

Answer: 

(c) stress management technique 

(iv) The Recycle Bin allows users to 

(a) permanently delete files 

(b) restore deleted files 

(c) increase memory 

(d) access internet settings 

Answer: 

(b) Restore deleted files 

(v) Which of the following is a myth about entrepreneurship? 

(a) Entrepreneurs never fail in business 

(b) Entrepreneurs take risks 

(c) Entrepreneurs create jobs 

(d) Entrepreneurs bring innovation 

Answer: 

(a) Entrepreneurs never fail in business 

(vi) Which of the following is a responsible way to protect cultural heritage and indigenous 

knowledge? 

(a) Ignoring traditional farming practices 

(b) Promoting local crafts and customs 

(c) Destroying old monuments 

(d) Avoiding folk tales and oral history 

Answer: 

(b) Promoting local crafts and customs 

Question 2. 

Answer any 5 out of the given 6 questions. (5×1=5) 

(i) Ansh inserted several images but now wants to resize them to maintain uniformity. Which 

method is best? 

(a) Resize using comer handles 

(b) Use save as 

(c) Use replace image 

(d) Use hyperlink 

Answer: 

(a) Resize using comer handles 

 (ii) Rohit added a comment while reviewing a document. How can he remove it later? 

(a) Go to Insert → Delete 

(b) Right-click the comment and select Delete 

(c) Remove from Format tab 

(d) Clear all contents 

Answer: 

(b) Right-dick the comment and select Delete 

(iii) Which category of styles applies to table formatting? 

(a) Frame 

(b) Paragraph 

(c) Table 

(d) List 



Answer: 

(c) Table 

(iv) What does anchoring an object mean in Writer? 

(a) Locking the object 

(b) Changing the file format 

(c) Setting its fixed position relative to text or page 

(d) Exporting it to another app 

Answer: 

(c) Setting its fixed position relative to text or page 

 (v) What is the default wrapping mode when inserting an image? 

(a) In Background 

(b) Page Wrap 

(c) No Wrap 

(d) Optimal Page Wrap 

Answer: 

(d) Optimal Page Wrap 

(vi) Shivani created a new style using formatting from selected text. Which method did she 

use? 

(a) From Template 

(b) From Selection 

(c) Fill Style 

(d) Style Updater 

Answer: 

(b) From Selection 

Question 3. 

Answer any 5 out of the given 6 questions. (5×1=5 ) 

(i) Which of the following lets you test different values in formulas without changing the 

original data? 

(a) Filters 

(b) Scenarios 

(c) Cell formatting 

(d) Autofill 

Answer: 

(b) Scenarios 

 (ii) A macro created in Libre Office is saved in 

(a) txt format 

(b) As part of the document 

(c) ods settings 

(d) Clipboard 

Answer: 

(b) As part of the document 

(iii) What is the purpose of absolute hyperlinks? 

(a) Link to undefined cells 

(b) Link to external documents with full path 

(c) Move sheets 

(d) Format cells 

Answer: 

(b) Link to external documents with full path 



(iv) After enabling ‗Track Changes‘, what does Calc display to indicate changes made? 

(a) Highlighted cells with details of the change 

(b) Hidden comments 

(c) Password prompts 

(d) Automatically saves the document 

Answer: 

(a) Highlighted cells with details of the change 

(v) Which feature allows adding input from other spreadsheets into one? 

(a) Chart 

(b) Consolidate 

(c) Sort 

(d) Scenario 

Answer: 

(b) Consolidate 

(vi) Where can you find the Scenario Manager in Calc? 

(a) Data → Scenarios 

(b) Tools → Macro 

(c) Edit → Scenario 

(d) Insert → Object 

Answer: 

(a) Data — Scenarios 

Question 4. 

Answer any 5 out of the given 6 questions. (5×1=5) 

(i) In a One-to-Many relationship 

(a) one record in the first table matches only one record in the second table. 

(b) one record in the first table matches many records in the second table. 

(c) many records in the first table match many records in the second table. 

(d) both tables have the same number of records. 

Answer: 

(b) one record in the first table matches many records in the second table. 

(ii) Which data model organises data in a tree-like structure? 

(a) Relational 

(b) Network 

(c) Hierarchical 

(d) Structural 

Answer: 

(c) Hierarchical 

(iii) Which type of field is used to store whole numbers? 

(a) Boolean 

(b) Integer 

(c) Float 

(d) Text 

Answer: 

(b) Integer 

(iv) What is the default extension of a LibreOffice Base file? 

(a) .odb 

(b) .ods 

(c) .odt 

(d) .odg 



Answer: 

(a) .odb 

 (v) Which view allows manual design of queries? 

(a) Wizard 

(b) Design View 

(c) Report View 

(d) Table View 

Answer: 

(b) Design View 

(vi) A query that uses mathematical calculations is a 

(a) Text Query 

(b) SQL Query 

(c) Numerical Query 

(d) Mathematical Query 

Answer: 

(c) Numerical Query 

Question 5. 

Answer any 5 out of the given 6 questions. (5×1=5) 

(i) If someone collapses due to cardiac arrest, the first action should be 

(a) try to revive them yourself. 

(b) move them to comfort. 

(c) call emergency services. 

(d) look for ID card. 

Answer: 

(c) call emergency services 

(ii) In ergonomics, the chair used at the computer workstation should have 

(a) Fixed backrest 

(b) Wheels only 

(c) Lumbar support 

(d) Wooden seat 

Answer: 

(c) Lumbar support 

 (iii) One of the key causes of poor air quality at the workplace is 

(a) Excessive lighting 

(b) Blocked ventilation 

(c) Cold weather 

(d) Empty bins 

Answer: 

(b) Blocked ventilation 

(iv) First-aid for burns includes 

(a) applying ice directly. 

(b) covering with dirty cloth. 

(c) running cool water over the burn. 

(d) scrubbing the burn area. 

Answer: 

(c) running cool water over the bum 



(v) A warning sign near electrical panels is an example of 

(a) safety hazard 

(b) risk management tool …….. 

(c) office design 

(d) equipment layout 

Answer: 

(b) risk management tool 

 

(vi) In the event of fire, one must 

(a) hide in a room 

(b) collect belongings 

(c) use the lift 

(d) evacuate immediately 

Answer: 

(d) evacuate immediately 

Section B 

Subjective Type Questions [26 Marks] 

Answer any 3 out of the given 5 questions on Employability Skills. Answer each question in 

20-30 words. (3×2=6) 

Question 6. 

What is the importance of feedback in the communication cycle? 

Answer: 

Feedback is essential in the communication cycle because it confirms whether the message 

was understood correctly. It allows the sender to know if the communication was effective or 

needs clarification. Feedback ensures the message is complete. helps avoid confusion and 

improves mutual understanding. 

Value Point 

Feedback confirms message understanding and helps correct or improve future 

communication. 

Question 7. 

Describe the qualities required to complete a task independently. 

Answer: 

To work independently, a person must be self-disciplined, goal.oriented and responsible. 

They should know how to plan activities, manage time and complete tasks without help. 

Confidence, focus, and problem-solving skills are also necessary to overcome challenges and 

complete the task efficiently within the given time frame. 

Question 8. 

What is a file and how is it organised in a computer system? 

Answer: 

A file is a digital document used to store data, such as text, images or programs, Files are 

organised in folders (directories) and subfolders in a tree-like structure. This helps manage, 

access and store files efficiently on a storage device. 

 



Question 9. 

Why is entrepreneurship a good career option? 

Answer: 

Entrepreneurship is a rewarding career because it offers independence, flexibility and the 

opportunity to pursue one‘s passion. It allows individuals to create value, generate income 

and make a social impact while achieving personal growth and financial success. 

Question 10. 

How can rainwater harvesting promote sustainable development? 

Answer: 

Rainwater harvesting collects and stores rainwater for future use. It reduces dependence on 

groundwater, prevents water wastage and ensures water availability during dry seasons. This 

eco-friendlv method helps in conserving water — a crucial step toward sustainable living. 

Answer any 4 out of the given 6 questions in 20-30 words each. (4×2=8) 

Question 11. 

How can a new style be created using the ‗From Selection‘ method in Writer? 

Answer: 

To create a new style from the selection, first format a paragraph, text, or object as desired. 

Then open the Styles and Formatting window, click on the drop-down menu, and select New 

Style from Selection. This saves the selected formatting as a new style that can be applied 

elsewhere in the document easily. 

Question 12. 

What is the use of creating references between multiple sheets in Calc? 

Answer: 

Creating references between sheets allows data from one sheet to be used in formulas in 

another. For example, you can total expenses from ―Sheeti‖ and show the result in ―Sheet2.‖ 

This method helps keep data organised. avoids duplication, and maintains dynamic 

connections—so when data in the original sheet changes, the referenced sheet updates 

automatically. 

Question 13. 

What is the process of accepting or rejecting changes in a shared spreadsheet? 

Answer: 

After recording changes in a shared CaIc file, users or reviewers can go to Edit — Track 

Changes — Manage Changes to see the list of modifications. Each change can be reviewed 

individually and either accepted or rejected. This feature ensures that only approved edits are 

finalised, maintaining control over collaborative document editing. 

 

Question 14. 

Explain the process of creating a table in LibreOffice Base using the Wizard. 

Answer: 

To create a table using the wizard in LibreOffice Base, follow these steps: 

 Open your database and select ‗Tables‘ from the left pane. 

 Click ―Use Wizard to Create Table.‖ 

 Choose a categmy and a predefined sample table, 

 Select the fields you want to include, rename them if needed and set data types. 

 Choose a primary key and dick ‗Create‘. 

 This method is beginner-friendly and helps build tables quickly. 



Question 15. 

What are the key steps to follow during a fire emergency in the workplace? 

Answer: 

During a lire emergency. activate the alarm immediately and evacuate the premises calmly 

through designated exits. Avoid using elevators. Follow the fire safety plan and assist others 

if needed. Do not re-enter the building until it is declared safe by the fire department- Fire 

drills and awareness training ensure everyone knows how to respond promptly and safely. 

Question 16. 

What safety measures should be taken while handling office equipment? 

Answer: 

Use equipment only after proper training and follow manufacturer guidelines. Ensure 

machines are turned off after use and report any malfunctions. Avoid wearing loose clothing 

or accessories that may get caught in equipment Regular maintenance and keeping 

emergency shut-off switches accessible are vital for preventing accidents. 

Answer any 3 out of the given 5 questions in 50-80 words each. (3×4=12) 

Question 17. 

(a) What is the purpose of using templates in LibreOffice Writer? 

Answer: 

Templates in Libre office Writer provide a predefined layout and formatting for new 

documents. They include styles head ings. 

logos, and default text placeholders. Using templates ensures consistency across documents 

and saves time by eLiminating 

repetitive formatting. They are especially useful in workplaces for creating standardised 

letters. reports and forms. Writer offers both in-built and user-created templates to suit 

different needs. 

(b) Describe how you can modify a form in LibreOffice Writer. 

Answer: 

Modifying a form in Wnter Involves accessing the Form Design toolbar. You can select form 

controls like test boxes, labels, or combo boxes and adjust properties such as size, name, and 

default value. You may also add new controls or remove existing ones. This allows 

customisation of user interaction within the document, particularly useful for creating 

interactive forms, surveys or data entry sheets. 

Question 18. 

Mr. Rajiv, a school administrator, manages monthly expenses in different sheets for 

departments like Sports, Library, and IT. He wants to summarise all expenses, create quick 

calculations and share the spreadsheet with department heads for feedback. 

(a) What feature should Mr. Rajiv use to combine department expenses into one sheet? 

(b) How can he simplify entering monthly budget headings across all department sheets? 

(c) Rajiv wants to test if reducing Library funds by 10% affects total expenses. Which tool 

should he use? 

(d) How can Mr. Rajiv ensure all changes by department heads are visible for review? 

Answer: 

(a) Mr. Rajiv can use the Consolidate feature from the Data menu. It helps him merge values 

from multiple sheets into one summaty sheet using functions like Sum, Average, etc. 

(b) He can record a macro to enter headers such as 7anuar‖ ―February‖ etc., once and then 

run the macro on each sheet. This saves time and ensures consistency. 

(c) He can use the What-U Scenario tool to create two versions: original and reduced Library 

budget. Switching between them shows the difference in total expenses. 



(d) The should enable Track Changes from the Edil Track Changes -s Record menu. This 

logs all edits, which he can later review, accept or reject. 

 

Question 19. 

You are conducting a workshop for new recruits who spend 6 – 8 hours daily on computers. 

You must explain good ergonomic practices and health tips. 

(a) What are two ergonomic tips to follow while using a computer? 

Answer: 

Proper ergonomies involve maintaining an upright posture with feet flat on the floor and the 

monitor at eye level. The keyboard and mouse should be pesutioned so elbows stay bent at 

about 90 degrees. Use a chair with lumbar support to prevent back pain. Also, take short 

breaks every hour to stretch or walk. These practices reduce the risk of musculoskeletal 

disorders, fatigue and eye strain among computer users. 

(b) Name two health issues caused by prolonged computer use. 

Answer: 

Long hours on a computer can cause eye strain. resulting in blurry vision, dryness and 

headaches. Additionally, poor posture may lead to chronic necic back and shoulder pain. 

These issues, collectively called Computer Vision Syndrome or occupational Overuse 

Syndrome. can impact work productivity and personal well-bein Preventive measures such as 

ergonomic setups. adequate lighting, and scheduled breaks help reduce these risks and 

maintain physical health during extended computer use. 

Question 20. 

(a) What are the main advantages of using a Database Management System (DBMS) 

compared to traditional file-based systems? Explain briefly. 

Answer: 

A DUMS reduces data redundancy by storing information centrally rather than In separate 

hies. 

 It maintains data integrity through constraints like pnmarv and foreign keys, 

 Security features including user authentication and encryption protect sensitive 

information. 

 Multiple users can access and modify data simultaneously without conflicts. 

 Automated backup and recovery systems prevent permanent data baa. 

 All applications access the same updated information. ensuring consistency. 

(b) What is a Relational Database Model and why is it widely used? 

Answer: 

The Relational Database Model organises data into tables (relations) consisting of rows and 

columns. Each table has a unique key and is related to other tables through foreign keys. It is 

widely used due to its simplicity flexibility and ease of understanding. Users can query data 

using SQI. and normalisation reduces redundance making it suitable for various applications 

like banking, education and inventory management. 

Question 21. 

Consider the following table: 

Roll No Name Subject Marks 



101 

102 

103 

Neha 

Ravi 

Neha 

English 

Maths 

English 

78 

88 

78 

(a) Suggest suitable data types for the Roll_No and Marks fields 

Answer: 

(a) Roll_No Integer (since it stores numeric student mil numbers) 

Marks Integer (to store whole number marks, but Decimal Numeric could also be used it 

fractional marts are possible). 

 

(b) Which field should be set as the primary key and why? 

Answer: 

(b) Field Roll_No 

Roll_No uniquely identifies each student record (no duplicates), is non-null, and remains 

constant (unlike names or subjects, which may repeat). 

Mistake Alert 

Students often select Names as the primary key because they assume names are unique. 

However, names can repeat, while Roll_No is always Unique and non-null, making it the 

correct choice for a primary key. 

(c) Identify a possible alternate key and justify. 

Answer: 

Field Name + Subject + Marks combination While names and subjects may repeat (e.g., 

―Neha‖ in ―English‖), the combination with Marks ensures uniqueness, as no two students 

share the same name, subject and marks. 

(d) How many attributes and records are present? 

Answer: 

Attributes (Columns) 4 (Roll_No, Name, Subject, Marks) 

Tuples (Records) 3 (Rows for Roll No 101, 102, 103) 
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Section A 

Objective Type Questions (24 Marks) 

Question 1. 

Answer any 4 out of the given 6 questions on Employability Skills. (4×1=4) 

(i) While speaking to a teacher, Arun kept slouching and checking his watch repeatedly. 

What does Arun‘s body language likely communicate? 

(a) He is respectful and attentive. 

(b) He is nervous but interested. 

(c) He is uninterested or impatient. 

(d) He is excited and ready. 

Answer: 

(c) He is uninterested or impatient. 

 (ii) What does the SMART acronym stand for in goal setting? 

(a) Simple, Manageable, Accurate, Reliable, Timely 

(b) Specific, Measurable, Achievable, Relevant, Time-bound 

(c) Small, Medium, Achievable, Realistic, Trackable 

(d) Strong, Meaningful, Applicable, Reasonable, Time-efficient 

Answer: 

(b) Specific, Measurable, Achievable, Relevant, Time-bound 

(iii) Zara enjoys long walks in the park after a hectic day at school to feel refreshed. This is 

an example of 

(a) nature walk as a stress buster. 



(b) peer pressure. 

(c) poor time management. 

(d) emotional dependence. 

Answer: 

(a) nature walk as a stress buster. 

School supplies 

(iv) In the Windows OS, right-clicking on a file and selecting ‗Rename‘ allows a user to 

(a) Delete the tile 

(b) move the file to another folder 

(c) change the file name 

(d) copy the file 

Answer: 

(c) Change the file name 

 (v) Which of the following statements about entrepreneurship as a career is correct? 

(a) It has no scope. 

(b) It only suits rich people. 

(c) It offers independence and opportunities. 

(d) It is always easier than jobs. 

Answer: 

(c) It offers independence and opportunities 

(vi) Which of these actions best reflects environmental citizenship? 

(a) Throwing waste in rivers 

(b) Conserving energy and water 

(c) Ignoring pollution rules 

(d) Wasting food and electricity 

Answer: 

(b) Conserving energy and water 

Question 2. 

Answer any 5 out of the given 6 questions. (5 x 1 = 5) 

 (i) Varun created a business letter template and now wants to reuse it for another letter. What 

should he do? 

(a) Save as draft 

(b) Use in-built template 

(c) Open Template and save as new document 

(d) Print directly 

Answer: 

(c) Open Template and save as new document 

(ii) Priya added a watermark but it‘s covering the text. What can she change? 

(a) Wrap setting 

(b) Layer order 

(c) Transparency 

(d) Paragraph style 

Answer: 

(c) Transparency 

(iii) Which of the following is a style category for bullet points‘ 

(a) Table 

(b) Character 

(c) List 



(d) Frame 

Answer: 

(c) List 

(iv) What does the term ‗Anchoring‘ refer to in Writer? 

(a) Creating links 

(b) Fixing objects to a part of the document 

(c) Making styles 

(d) Writing formulas 

Answer: 

(b) Fixing objects to a part of the document 

(v) Which menu helps in recording changes in a document? 

(a) Edit 

(b) View 

(c) Tools 

(d) File 

Answer: 

(c) Tools 

 (vi) Rajat deleted a Table of Contents by mistake, What is the best way to restore it? 

(a) Ctrl+Z 

(b) Reinsert using Insert → Table of Contents 

(c) Rebuild the whole document 

(d) Use Templates 

Answer: 

(b) Reinsert using Insert → Table of Contents 

Question 3. 

Answer any 5 out of the given 6 questions. (5×1=5) 

(i) Which feature helps compare changes made by different users in a spreadsheet? 

(a) Coal Seek 

(b) Merge Document 

(c) Format Cells 

(d) Autofilt 

Answer: 

(b) Merge Document 

(ii) The Subtotal feature is found under 

(a) Format 

(b) Tools 

(c) Data 

(d) View 

Answer: 

(c) Data 

(iii) After reviewing the changes, how can you stop others from editing the document further? 

(a) Disable sharing by unchecking ‗Share Document‘ in Tools 

(b) Turn off the computer 

(c) Remove Track Changes only 

(d) Save itas a read.only document 

Answer: 

(a) Disable sharing by unchecking ‗Share Document‘ in Tools 



(iv) A hyperlink in Caic can be used to 

(a) add borders 

(b) insert comments 

(c) navigate to another document 

(d) calculate totals 

Answer: 

(c) Navigate to another document 

(v) The shortcut to add a new comment in a Cale cell is 

(a) Ctrl + M 

(b) Ctrl + Alt + C 

(c) Ctrl + Shift + C 

(d) Ctrl + F2 

Answer: 

(b) Ctrl+Alt+C 

(vi) In Calc, which feature lets you see what others have edited in a shared document? 

(a) Scenario Manager 

(b) Consolidate 

(c) Track Changes 

(d) Paste Special 

Answer: 

(c) Track Changes 

Question 4. 

Answer any 5 out of the given 6 questions. (5×1=5) 

(i) Which feature in Base allows you to create structured output for printing data from tables 

or queries? 

(a) Report 

(b) Form 

(c) Table 

(d) Query 

Answer: 

(a) Report 

(ii) Which one of the following data types stores decimal numbers? 

(a) Integer 

(b) Text 

(c) Numeric (Decimal) 

(d) Boolean 

Answer: 

(c) Numeric (Decimal) 

(iii) What is the purpose of using a wizard in Base? 

(a) To enter data 

(b) To automate database tasks 

(c) To create database objects step-by-step 

(d) To write queries in SQL 

Answer: 

(c) To create database objects step-by-step 

(iv) Which control is used to show static text on a form in Base? 

(a) Text Box 

(b) Label 



(c) Combo Box 

(d) List Box 

Answer: 

(b) Label 

(v) A query that retrieves data based on specific criteria is known as 

(a) Static query 

(b) Conditional query 

(c) Filter query 

(d) Select query 

Answer: 

(d) Select query 

(vi) What ensures consistency and prevents orphaned records when tables are related? 

(a) Primary key 

(b) Foreign key 

(c) Referential integrity 

(d) Data type 

Answer: 

(c) Referential integrity 

Question 5. 

Answer any 5 out of the given 6 questions. (5×1=5) 

(i) Which of the following is a correct safety practice while using a paper shredder? 

(a) Push papers in with your fingers 

(b) Turn it on before plugging in 

(c) Keep hands away from the opening 

(d) Shred one large pile at once 

Answer: 

(c) Keep hands away from the opening 

(ii) What should you avoid doing during a fire emergency? 

(a) Use the stairs 

(b) Help others evacuate 

(c) Use the elevator 

(d) Follow the fire escape plan 

Answer: 

(c) Use the elevator 

(iii) What does Refer to MSDS mean when working with chemicals? 

(a) Maximum safe data score 

(b) Material Safety Data Sheet 

(c) Monthly supply demand system 

(d) Machine safety and disposal sheet 

Answer: 

(b) Material Safety Data Sheet 

(iv) Which of the following is a symptom of computer vision syndrome? 

(a) Knee pain 

(b) Dry eyes 

(c) Chest pain 

(d) Neck rash 

Answer: 

(b) Dry eyes 



(v) Which one of these is considered an ergonomic device? 

(a) Adjustable chair 

(b) Paper file 

(c) Loudspeakers 

(d) Mirror 

Answer: 

(a) Adjustable chair 

 

(vi) What should be done immediately after any workplace accident? 

(a) Ignore it 

(b) Inform your supervisor 

(c) Wait till end of shift 

(d) Cover it up 

Answer: 

(b) Inform your supervisor 

Section B 

Subjective Type Questions [26 Marks] 

Answer any 3 out of the given 5 questions on Employability Skills. Answer each question in 

20-30 words. (3×2=6) 

Question 6. 

What is descriptive feedback? Give an example. 

Answer: 

Descriptive feedback is detailed and specific, explaining what was done well and what needs 

improvement. It helps learners grow. For example, ―Your report was well-organized, but 

adding more data to support your argument would make it stronger‖ is an example of 

descriptive feedback. 

Question 7. 

Why is the ability to work independently important? 

Answer: 

The ability to work independently builds self-confidence, responsibility-and time 

management skills. It allows individuals to set and achieve goals without needing constant 

supervision. This quality is valuable in both academics and the workplace, as it encourages 

problem-solving and increases productivity. 

Question 8. 

Describe how to create, rename and delete a folder in a computer. 

Answer: 

 To create a folder Right-click → New xFolder. 

 To rename Right-click the folder → Rename → Type new name. 

 To delete Right-click → Delete or press Del key. 

These options help in organising and managing files and directories effectively. 

Question 9. 

How can students prepare themselves to become future entrepreneurs? 

Answer: 

Students can prepare by developing skills like communication, decision-making and 



problem-solving. Participating in business clubs, reading about entrepreneurs, attending 

workshops and working on small projects can build confidence. Learning from failures and 

being open to feedback also helps in building a strong entrepreneurial mindset. 

Online Tutoring 

 

Question 10. 

What are the benefits of respecting indigenous knowledge in sustainability? 

Answer: 

Indigenous knowledge includes traditional farming, water conservation and natural medicine 

practices. Respecting it helps protect biodiversity, preserve cultural heritage and promote 

eco-friendly practices. It offers valuable solutions for sustainable resource management and 

environmental conservation. 

Answer any 4 out of the given 6 questions in 20-30 words each. (4×2=8) 

Question 11. 

What does the Fill Format mode do in Writer? 

Answer: 

Fill Format mode in LibreOffice Writer lets users quickly apply an existing style to different 

parts of the document. By selecting the Fill Format tool in the Styles and Formatting window, 

and then clicking on text or objects, the selected style is applied instantly. This saves time and 

ensures uniform formatting across the document. 

Question 12. 

What are subtotals in Calc and how are they applied? 

Answer: 

Subtotals in Calc are used to calculate group-wise totals for large data sets. When you have a 

sorted list of items like sales by region, applying the Subtotal feature lets you see totals per 

region automatically. Calc inserts rows for each group showing the sum, average or other 

functions, making data analysis easier and faster. 

Question 13. 

What do you mean by recording changes in a spreadsheet? 

Answer: 

Recording changes in spreadsheet allows users to track modifications made to a shared 

spreadsheet. When this feature is turned on, Calc highlights added, deleted or edited content, 

along with the user‘s name and timestamp. This is useful for document review and 

collaboration, especially when multiple users are editing the same file. 

Question 14. 

Describe any two data types used in LibreOffice Base. 

Answer: 

Two common data types in LibreOffice Base are: 

 Text (VARCHAR) Used for storing alphanumeric data such as names, addresses, etc. 

 Number (INTEGER, DECIMAL) Used for storing numeric values. For example, 

INTEGER for age and DECIMAL for salary. 

 Selecting the appropriate data type ensures proper storage, validation and operations 

on the data, such as calculations or sorting. 

Question 15. 

What is the importance of regular cleaning and hygiene at the workplace? 



Answer: 

Maintaining cleanliness at the workplace helps prevent the spread of germs and reduces 

health risks such as respiratory infections or allergies. It also improves air quality and creates 

a pleasant, professional environment. Clean surfaces, sanitized washrooms and waste 

disposal systems are essential. Regular cleaning promotes employee health and enhances 

productivity. 

 

Question 16. 

What precautions should be taken when working near electrical equipment? 

Answer: 

Always ensure electrical devices are grounded properly and turned off when not in use. 

Avoid handling them with wet hands or near water. Use surge protectors and inspect cords 

for wear or damage. In case of an electrical emergency, shut off the power and seek 

professional help immediately. These practices help prevent shocks, fires and equipment 

damage. 

Answer any 3 out of the given 5 questions in 50-80 words each. (3×4=12) 

Question 17. 

(a) What is the function of the Alignment option in positioning images? 

Answer: 

The Alignment option in Writer helps position images in relation to the page or paragraph. 

You can align an image to the left, center, right, top or bottom. This ensures the image is 

placed exactly where desired, improving visual appeal and readability. Proper alignment is 

essential when combining images and text, especially in professional documents or 

presentations. 

(b) How does the ‗Accept or Reject Changes‘ feature help during document review? 

Answer: 

The ‗Accept or Reject Changes‘ feature in Writer allows you to review edits made by others 

during collaboration. It highlights insertions, deletions and formatting changes. You can go 

through each change and decide whether to keep or discard it. This ensures the final 

document is accurate, consistent and reviewed thoroughly. It is a vital tool for editors and 

collaborative writing tasks. 

Question 18. 

An accountant, Mr. Suresh, maintains annual sales records. He wants to automate tax 

calculation, apply different tax rates and allow colleagues to comment on the file. 

(a) How can he automate tax calculations for all rows? 

Answer: 

He can create a macro that applies a formula to calculate tax. Running this macro across all 

rows will quickly apply the calculation to every entry. 

(b) To apply two tax slabs ( 5% and 12% ) and see which benefits the company more, what 

tool should he use? 

Answer: 

He can use the Scenario Manager to create and switch between the two tax slabs. This helps 

him analyse which tax rate yields better financial results. 

(c) A colleague wants to suggest corrections. How can he add that in the file? 

Answer: 



The colleague can use Insert ? Comment to add notes on any cell. Mr. Suresh will be able to 

read and act on the suggestion later. 

(d) How can Mr. Suresh identify who made changes in the spreadsheet? 

Answer: 

By enabling Track Changes and using Edit ? Track Changes → Manage, he can view, accept 

or reject the changes made by others, along with their names. 

Question 19. 

Your company has recently experienced minor electric shocks in a few departments. You‘ve 

been asked to create a report and educate employees about the importance of electrical safety 

and how to respond during electrical emergencies. 

(a) What are two key electrical safety tips employees should follow? 

Answer: 

To ensure electrical safety, employees should never operate electrical equipment with wet 

hands, as it increases the risk of electric shock. Also, damaged plugs or exposed wires should 

never be used. These items must be reported immediately to a qualified technician for repair. 

Plug points should not be overloaded. Following these precautions can significantly minimise 

electrical hazards and protect both employees and office equipment from accidents or short 

circuits. 

 

Value Points 

Focus on common workplace risks: 

 Never use devices with wet hands. 

 Never use damaged plugs or wires. 

These are two frequently asked and easy to remember. 

(b) Mention two first aid measures to be taken during an electrical emergency. 

Answer: 

In an electrical emergency, the first step is to switch off the power source before touching the 

affected person to avoid further shocks. Next, use a non-conductive item like a wooden stick 

to separate the person from the electric source. If the victim is unconscious, check for 

breathing and pulse. Administer CPR if trained and call emergency services immediately. 

Always follow safety protocols and act quickly to prevent severe injury or death. 

Question 20. 

(a) What are reports in Base and how are they different from queries? 

Answer: 

Reports are formatted presentations of data retrieved from tables or queries, suitable for 

printing and sharing. While queries extract and filter data, reports are used to display this data 

attractively with headers, footers, page numbers, and formatting. They are useful for 

summarising information like monthly sales or student results, providing a clear and 

professional view for decision-making. 

(b) How can you insert date and time in a Base report? 

Answer: 

To insert date and time, open the report in edit mode and use the ‗Insert‘ menu to add a 

date/time field. You can place it in the header, footer, or any section of the report. This 

feature is useful for indicating when the report was generated and helps in record keeping and 

validation of printed data. 



 

Question 21. 

Consider the following table: 

Route_ID Start_Point End Point Driver.Name 

Ro1 

R02 

R03 

Sector 1 

Sector 5 

Sector 1 

School 

School 

School 

Rajesh 

Amil 

Rajesh 

(a) Suggest a suitable data type for the Route_ID and Driver_Name. 

Answer: 

Suggested Data Types 

 Route_ID Character/Varchar (to store alphanumeric route IDs like ―R01‖) 

 Driver_Name Varchar (to store names of variable length) 

(b) Which field should be set as the primary key and why? 

Answer: 

Primary Key Selection 

 Field Route_ID 

 Justification Route_ID uniquely identifies each bus route (no duplicates), is non-null, 

and remains constant (unlike start/end points or driver names, which may repeat). 

(c) Identify a possible alternate key and justify. 

Answer: 

Candidate Key 

 Field Start_Point + End_Point + Driver_Name combination 

 Reason While start and end points may repeat (e.g., ―Sector 1‖ to ―School‖), the 

combination with Driver_Name ensures uniqueness, as no two routes share the same 

start, end and driver. 

 

(d) How many attributes and records are present? 

Answer: 

Table Structure Analysis 

 Attributes (Columns) 4 (Route_ID, Start_Point, End_Point, Driver_Name) 

 Tuples (Records) 3 (Rows for R01, R02, R03) 

A. Mistake Alert 

Students often confuse between attributes and records. Columns = attributes, Rows = records 

mention exact count. 



 
 


